Merge #21264: fuzz: Two scripted diff renames

Merge #21264: fuzz: Two scripted diff renames

fae216a73d71441432cf07212313d18771ce7deb scripted-diff: Rename MakeFuzzingContext to MakeNoLogFileContext (MarcoFalke)
fa4fbec03e4395a6ab75ea98a696bee6d768e97e scripted-diff: Rename PROVIDE_MAIN_FUNCTION -> PROVIDE_FUZZ_MAIN_FUNCTION (MarcoFalke)

Pull request description:

  Split out two renames from #21003:

  * `PROVIDE_FUZZ_MAIN_FUNCTION`. *Reason*: This in only used by fuzzing, so the name should indicate that.
  * `MakeNoLogFileContext`. *Reason*: Better reflects what the helper does. Also, prepares it to be used in non-fuzz tests in the future.

ACKs for top commit:
  practicalswift:
    cr ACK fae216a73d71441432cf07212313d18771ce7deb: scripted-diff looks correct

Tree-SHA512: e5d347746f5da72b0c86fd4f07ac2e4b3016e88e8c97a830c73bd79d0af6d0245fe7712487fc20344d6cc25958941716c1678124a123930407e3a437265b71df

情報元 - Merge #21264: fuzz: Two scripted diff renames · bitcoin/[email protected] · GitHub

Merge #21264: fuzz: Two scripted diff renames · bitcoin/bitcoin@cac10e6 · GitHub
スポンサーリンク

シェアする

フォローする

スポンサーリンク

トップへ戻る